Routine to bypass a firmware

Page 8/10
1 | 2 | 3 | 4 | 5 | 6 | 7 | | 9 | 10

By Wierzbowsky

Guardian (3492)

Wierzbowsky's picture

27-07-2022, 12:44

foody wrote:
Manuel wrote:

Um, so you didn't realize that MM is just a program that can run on any MSX2 and doesn't need the MFR SCC+? You can just put it on your CF card and run it off your C2's Nextor/DOS2 for instance...

I was informed by the author of C2 himself that MM only works on MFC and does not work on C2. I was informed only SofaRun works with C2. I don't want to use SofaRUN myself, I prefer MM instead.

May I ask who told you that MM only works on MFR? MM is just a DOS program that works from any media, including CF and SD cards, as well as floppy drives.

By Wierzbowsky

Guardian (3492)

Wierzbowsky's picture

27-07-2022, 12:49

foody wrote:
sdsnatcher73 wrote:

It’s odd, C2 should always show the bootmenu. This is on your PHC-23? Do you have autostart set on some entry in the bootmenu? Can you make a video of the machine booting with only C2 and share it?

Here is the thing. If I don't press anything like F5 for example, I get the boot menu splash screen first then followed right away to the menu selection and so forth. I press return and go right to MSX 2 basic.

Pressing Enter in the Boot Menu should show the Dual-Slot configuration and not go to Basic. What version of firmware and Boot Menu do you have?

By foody

Champion (452)

foody's picture

27-07-2022, 21:18

OK. I have the version 2.52. I go to the boot menu, it is after the boot menu it goes to basic if I don't press f5 to activate the IDE. I am going to turn off my MSX2 and keep only the CF in the slot. I will try without pressing anything after bootmenu and pressing f5 after bootmenu. Hold on a second (I am skipping megaflash).

By foody

Champion (452)

foody's picture

27-07-2022, 21:21

I was right. It went straight to basic. Hmmm....let me see something else....brb.

By foody

Champion (452)

foody's picture

27-07-2022, 21:36

OK...I have couple of issues.

Issue 1:

When I press return to save my settings after I did some changes when I pressed o for configuration of slot 1 and slot 2 it doesn't work...I can only press ESC

Issue 2:

On the bootmenu the autostart is not checked and pressing A does not work

Also I noticed the firmware is 2.50 while the boot menu is 2.52. Any idea how I can upgrade the firmware to 2.52 without using USB blaster? Thanks in advance.

By foody

Champion (452)

foody's picture

27-07-2022, 22:04

I am having issue saving the information or settings in my c2. Everytime after soft restarting or power cycling my msx the information is gone. Any advise?

By Wierzbowsky

Guardian (3492)

Wierzbowsky's picture

27-07-2022, 23:43

foody wrote:

I am having issue saving the information or settings in my c2. Everytime after soft restarting or power cycling my msx the information is gone. Any advise?

In Boot Menu press D. Then go to configuration settings by pressing C, press HOME and ESC, then enter configuration settings again, change some settings and press ESC again. Power down and up again and see if the settings are preserved. If not, there may be an issue with your configuration EEPROM. You can dump configuration EEPROM's data to disk using the c2cfgbck utility. Send this file to me or post here and I will check it.

I still don't get why you keep pressing F5. F5 bypasses Boot Menu and should start Nextor that will load DOS2 from CF card...

By foody

Champion (452)

foody's picture

28-07-2022, 01:37

Because if I don't press F5 it goes right to basic...nextor and cf boot is ignored! It is when I keep holding on F5 that it actually works...ok..let me follow your instruction again.

By foody

Champion (452)

foody's picture

28-07-2022, 01:51

Ok...this is what happens...if I go to slot and press o and do settings there and restart MSX those settings are gone that is number 1. Number 2 if I press nothing I get to the bootscreen, there are no ROMs in the bootscreen naturally, so I press return and it applies nothing so I end with MSX basic. Because I put nothing in the bootscreen as there are no ROMs to flash.

So in order for me to go to the CF I need to press F5. Well two scenarioes happens.

Scenario 1:

If I don't press F5 and the settings on slots are erased fmpac does not work.

Scenario 2:

If I press F5 and go to nextor that is when it should have fmpac working and RAM working as long as the slot information are not deleted or gone.

I have placed screenshot of slot configuration before and after restart.


As you can see the settings are gone everytime I restart. My problem f I don't press F5 and bypass bios and go to CF nextor the available RAM and fmpac features don't work! So all the time before this new problem showed up I had always had to press f5 which was annoying that is all.

Now I have a bigger problem...the settings for slots are no longer saving...what do you recommend I do?

By Manuel

Ascended (18948)

Manuel's picture

28-07-2022, 08:10

Is this all with or without the MFR SCC inserted as well?

Page 8/10
1 | 2 | 3 | 4 | 5 | 6 | 7 | | 9 | 10