Philips NMS8250 SD-512 problems?

Page 2/3
1 | | 3

By Djeroek

Supporter (12)

Djeroek's picture

21-05-2022, 11:51

I'll try your suggestion this afternoon GDX, I was hoping this was a familiar issue with the 8250 and SD-512 cartridge with an easy fix, but perhaps it makes more sense / faster if I can buy a disk with moonblaster on it from a Dutch member? Would be great to try and make some music with this machine, I dont necessarily need to play games.

By Djeroek

Supporter (12)

Djeroek's picture

22-05-2022, 01:20

Quote:

Try to remove the partition witn a PC or Mac, and retry to format it and create the partition with _FDISK. Then if it works, copy NEXTOR.SYS and COMMAND2.COM to the disk.

Just tried it and this didn't work unfortunately.

Some random things I've noticed checking out the boot sequence of the NMS-8250 on youtube is that when starting up I can see the mention of "VIDEO RAM" & "USER RAM" (https://www.youtube.com/watch?v=-0xhHgh1VZE), while when I start up my NMS with SD-512 cartridge inserted I see;
[img]20220518_202857 by Hiek A Matiek, on Flickr[/img]
Also in other youtube videos running the NMS-8250 I can see options in the bottom of the screen, namely from left to right; color, auto, goto, list & run. These aren't visible on my computer, does the above raise any clues, hints on what might be wrong?
Does the NMS have options to boot it in different modes, some kind of bios/settings screen, holding a key during start-up?

By Manuel

Ascended (18779)

Manuel's picture

22-05-2022, 01:42

The ram display you have in that picture tells me it is not the original ROM of the 8250. But it should not be related to the issue you're running into.

By Djeroek

Supporter (12)

Djeroek's picture

22-05-2022, 02:03

Quote:

The ram display you have in that picture tells me it is not the original ROM of the 8250. But it should not be related to the issue you're running into.

Do you know of a basic command that can list the specifications of the machine, give more info?

Anyway, I think the machine might be faulty as I have a few extension cartridges that have programs build in like the "music module" & "HX-MU900", though when I plug these in, they wont automatically boot into the build in software. Actually the music module does when I hold escape during start-up (or enter call musicbox or _musicbox in basic), but the screen is glitched out, garbled so unusable. The HX-MU900 cartridge seems to run in a reset loop, until I hold esc and it will exit into basic. I have to google to see if this is normal behavior for these cartridges in the 8250.

Last resort is I want to see if it can run disks, if this also fails I'll look for another MSX2 in the secondhand market / eventually get this one fixed.

By gdx

Enlighted (5480)

gdx's picture

22-05-2022, 02:37

Boot sequence is variable on Philips computers. It's not always the mention of "VIDEO RAM" & "USER RAM". The total RAM display is displayed with newer versions of ROM. Check that the characters displayed all correspond to the keys on your keyboard. Try running programs to check RAM and VRAM if the floppy disk drive works.

Here is some utilities to check the RAM:
https://www.msx.org/downloads/utilities/miscellaneous/chkmem-11
https://www.msx.org/downloads/mapper-info-ver12
https://www.msx.org/downloads/memtest-memory-tester
http://caro.su/msx/mem4msx/testmap.zip

Check also the cartridge contacts and its welds.

By sdsnatcher73

Prophet (3210)

sdsnatcher73's picture

22-05-2022, 06:10

I can send you a floppy with MoonBlaster on it. Try cleaning the cartridges (the connector can get dirty over time). If the machine needs repairs but you want to start making music I can take the machine as trade in on a working MSX2 (as in already repaired Wink).

By Briqunullus

Champion (512)

Briqunullus's picture

22-05-2022, 07:48

Manuel wrote:

The ram display you have in that picture tells me it is not the original ROM of the 8250. But it should not be related to the issue you're running into.

Opening post contains a picture showing MSX Basic 3.0. The machine has been converted to MSX 2+.

By Manuel

Ascended (18779)

Manuel's picture

22-05-2022, 10:18

Ah indeed, that explains the ram display. I think indeed the cartridge edges an/or slot connector is dirty. Did you try the other cartridge slot as well?

By Djeroek

Supporter (12)

Djeroek's picture

23-05-2022, 08:44

Thanks all for the help!

I'll send you a pm soon @sdsnatcher73 . I have ordered some WD-40 contact spray version and will check the cartridge contacts soon. I did manage to format a former Amiga 500 game double density Disk on the msx using call format, unfortunately my usb floppy diskdrive (FD-05PUB) doesn't seem to support Double Density disks in Disk Manager on the windows 10 pc. Will look into usb floppy diskdrives that do support Double Density disks.

edit: I did try the other slot as well with similar faulty results Sad

By Djeroek

Supporter (12)

Djeroek's picture

24-05-2022, 13:03

Finally, some succes Smile . I've formatted the sd card on my raspberry pi using Gparted. Creating 2 partitions, a small unspecified partition of 16 mb and another partition being fat16 where I put Sofarun, games, boot files et cetera.

Now when I start up the Msx, it does boot up with an A:\> prompt like in the youtube video in the first page of this thread;
[img]20220524_125440 by Hiek A Matiek, on Flickr[/img]

And using the same steps as in aforementioned youtube video, I can boot up rom games!
[img]20220524_125312 by Hiek A Matiek, on Flickr[/img]

Now to find out how to start the disk image of Moonblaster and getting the music module to work with it. Glad to have at least come this far :) .

Page 2/3
1 | | 3